NEXUS DSP - Nexus monitor is back up – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
Dark mode
All systems operational
Nexus monitor is back up
Resolved
Major outage
Started 16 days ago
July 05, 2026
Lasted 5 days
July 05, 2026
11:16 PM
July 10, 2026
6:24 PM
UTC
Affected
Nexus monitor
Operational from 11:16 PM to 11:16 PM, Major outage from 11:16 PM to 6:24 PM
Updates
Resolved
July 10, 2026 at 6:24 PM
UTC
Resolved
July 10, 2026 at 6:24 PM
UTC
Nexus monitor is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
July 05, 2026 at 11:16 PM
UTC
Investigating
July 05, 2026 at 11:16 PM
UTC
UTC
UTC
UTC
UTC
UTC